蓝盟诗人[LUC]蓝客联盟

忘记密码

DNF十三章 最全基址+偏移+写法+所有职业技能

2011-04-18 23:07 作者: 来源: 本站 浏览: 2,899 views 我要评论 字号:

人物基址   01213B0C
QQ基址   011BA4C4 
角色基址   011A4D30
召唤基址   016865D8 
仓库基址   009D2920
物品栏偏移=3860  
商店基址   011BD304
动作CALL   2B4
物品CALL   4CC
公告基址   00BF0F60
公告地址   00AFE2D0   
喇叭公告   00AFF980 
攻击对象   01686E0C
技能参数1  010BEF68
技能参数2  010BEF6C
技能栏偏=37DC
加密参数1  013D6A98
加密参数2  013D6A9C
装备参数1  0127C158
装备参数2  0127C15C
装备CALL   00446830
地图基址   010ADDF8
评分基址   011B7990
怪物数量   01215C88
头部参数   0129BFD8
x轴参数    00BFEFD0
Y轴参数    00BFEE80
z轴参数    00BFF150
过图CALL   004A2B10
对话CALL   011BD2FC
APC 公告   00403820
喊话CALL   00AFFD90    
模拟CALL   00514FD0    
人物等级=10CC
最大血量=10D4
最大蓝=10E4
当前血偏移=1BCC
当前蓝偏移=1BD4
恢复HP=12D4
MP恢复=12E4
虚弱=33E8
不死=1F0C
卖修偏移1CB8  
属性偏移:
人物等级=10CC
力量=10F4
体力=1104
智力=1114
精神=1124
火属性抗性=1134
冰属性抗性=113C
暗属性抗性=1144
光属性抗性=114C
火属性抗性=1120
火属性强化=1174
冰属性强化=117C
暗属性强化=1184
光属性强化=118C
负重=12C4
移动速度=12F4
攻击速度=1304
释放速度=1314
硬直=1324
僵直=1334
物理攻击=1374
物理防御=1384
魔法攻击=1394
魔防防御=13A4
物理攻击无视防御=13B4
物理防御追加伤害=13BC
物理防御负数0=13C4
无视防御魔法伤害=13CC
魔法防御追加加减少=13D4
魔法防御负数0=13DC
物理暴击=13E4
魔法暴击=13EC
命中=140C
物理攻击=13F8
物理防御 百分比=1434
魔法攻击=1408
魔法防御 百分比=1444
城镇物理攻击=19AC
城镇物理防御=19B4
城镇魔法攻击=19BC
城镇魔法防御=19C4
城镇移动速度=19D4
霸体=F14
 
装备偏移:
武器=1EC4
衣服=1ECC
护腿=1ED4
护肩=1ED0
腰带=1EDC       
鞋子=1ED8
称号=1EC8
护腕=1EE4
项链=1EE0
戒指=1EE8
装备属性偏移:      
最大耐久=178        
+HP=1C0    
+MP=1D0
+MP%=1D8
+力量=1E0
+体力=1E8
+智力=1F0
+精神=200    
+物理攻击=208
+物理防御=218
+魔法攻击=228 
+魔法防御=238
+无视物击=268
减物伤害=2A0 
减物理伤害%=2A8
+无视魔攻=280
减魔伤害=2E8
火抗=2F8
冰抗=300
暗抗=308
光抗=310       
所有属性抗性=2E8
减速=2F0
冰冻抗性=2F8
中毒抗性=300
回避=358    
在抗性=370
所有抗异常=378
负重=380
回HP=388
回MP=390
回MP%=398
移动速度=3A0
攻速=3B8
释放速度=3C0
硬直=3C8
跳跃=3D0
物理暴击=2D8
魔法暴击=2E0
攻击属性=3E4
击飞+=4D4
浮空+=4DC
-命中=4E4
硬直=3C8
火属性强化=564
冰属性强化=56C
暗属性强化=574
光属性强化=57C
 
魔法师 - 稻草人=0064BB5B
魔法师 - 炫纹水=007F9DE0
魔法师 - 魔法星弹=00792438
魔法师 - 杰克爆弹=00792574
魔法师 - 冰霜雪人=0079279D
魔法师 - 电光曼=00792928
魔法师 - 黑猫=00792AC0
魔法师 - 虚无之球=00792C73
魔法师 - 杰克降临=006CD121
魔法师 - 舒露露吸怪=0079459D
魔法师 - 魔力印记=00794B46
魔法师 - 雷电=00895137
魔法师 - 天雷闪=0082AD3B
魔法师 - 黑洞=00794134
魔法师 - 极冰盛宴=00793759
魔法师 - 圆舞棍=0077FF5E
魔法师 - 落花掌=00779ED3
魔法师 - 强压炫纹=0078016C
魔法师 - 黄龙=007805E6
魔法师 - 改良魔法星弹=0079618F
魔法师 - 反重力装置=006C0941
魔法师 - 精灵王半月=0085E8FE
魔法师 - 精灵王激光=0085EB82
魔法师 - 暴炎加热炉=00790580
魔法师 - 大电精灵电=01D150C1
魔法师 - 大冰精灵冰=01CAC13F
魔法师 - 大电精灵小电=01CFA6C1
魔法师 - 上火精灵半月=0089126F
魔法师 - 地上小针=008CC608
魔法师 - 召唤宝宝的万剑诀=0083AD0C
格斗家 - 念气波=008636D9
格斗家 - 抛沙=00725177
格斗家 - 狮子吼=00739641
格斗家 - 分身=00738FED
格斗家 - 念气环绕=007397C6
格斗家 - 彗星落=00728B91
格斗家 - 念气罩1=0073984C
格斗家 - 抓轰炮=00739421
格斗家 - 擒月炎=0072ACEB
格斗家 - 蜘蛛网=007252EE
格斗家 - 下段踢=007293A3
格斗家 - 龙卷风=00733D28
格斗家 - 气功觉醒=0042DA9F
格斗家 - 升龙=0064C6D4
格斗家 - 街头风暴=00725E79
格斗家 - 金刚碎=00726C95
格斗家 - 烈石破天=00737208
格斗家 - 电光龙头=00727ACD
格斗家 - 龙虎啸虎头=00687BEC
格斗家 - 气功觉醒=0042DA9F
鬼剑士 - 波动剑=00649A12
鬼剑士 - 半月=00649A52
鬼剑士 - 怒气爆发=007E281A
鬼剑士 - 刀魂之卡赞=007E27F4
鬼剑士 - 红阵=007E2CA8
鬼剑士 - 冰阵=007E2D34
鬼剑士 - 绿阵=007B3C73
鬼剑士 - 墓碑=007E2EFC
鬼剑士 - 银光落刃=007D2506
鬼剑士 - 抓头=007CF275
鬼剑士 - 无影像=007E308B
鬼剑士 - 小邪光斩=0082B8F4
鬼剑士 - 前突刺第二刀=007DF58B
鬼剑士 - 虚电球=00649D66
鬼剑士 - 裂波斩=007CD627
鬼剑士 - 嗜灵鬼斩=007D9262
鬼剑士 - 火波爆=00753F46
鬼剑士 - 鬼闪=007DB135
鬼剑士 - 锁人球=007CD3FE
鬼剑士 - 十字斩=007CDA11
鬼剑士 - 里鬼双刀=007C52FC
鬼剑士 - 地光阵=007CF8D8
鬼剑士 - 周身烧=007E288D
鬼剑士 - 光球定珠=007CFE1D
鬼剑士 - 幻影剑舞第五刀=007CE4D3
鬼剑士 - 不动明王的球=007CCC8F
鬼剑士 - 格挡气球=007CC15B
鬼剑士 - 瘟疫之罗刹=007E2E73
鬼剑士 - 血之咆哮=007C76AA
鬼剑士 - 大崩山=00733325
鬼剑士 - 大崩山火山浮空=0067F1A0
鬼剑士 - 卡洛空中=0064CAA6
鬼剑士 - 卡洛灼烧=0067EA2D
鬼剑士 - 小黑爆炸定珠爆=00632E1E
鬼剑士 - 小崩山=007CE19C
鬼剑士 - 白手觉醒=0064A32A
鬼剑士 - 狂战觉醒=007D0475
鬼剑士 - 鬼泣觉醒=007E092E
鬼剑士 - 修落翅膀=007C58A8
鬼剑士 - 修罗觉醒轮子=007CBD93
神枪手 - 蓄电激光=00752C91
神枪手 - 踏射=006171F3
神枪手 - 爆炎弹=006AF031
神枪手 - 空投支援=0075A8B2
神枪手 - 空中战机的导弹=0083947E
神枪手 - 空中战机爆炸=00837FCC
神枪手 - 空投爆炸=0082B054
神枪手 - 机械觉醒=00761CB3
神枪手 - 黑玫瑰战队=0075C68A
神枪手 - 冰冻弹=006AED47
神枪手 - 银弹=0062CA80
圣职者 - 落凤锤=0064CA09
圣职者 - 意念=0079B79A
圣职者 - 恶魔之手=007BBB7E
圣职者 - 移动墙=007A8032
圣职者 - 圣光球=007BBD2A
圣职者 - 旋风=007A71FC
圣职者 - 破魔符=007A9F27
圣职者 - 镇压符=007AA0C7
圣职者 - 落雷符=007AA249
圣职者 - 狂乱锤击=007A7BE0
圣职者 - 潜龙=007A5BF9
圣职者 - 满蓄力空斩打=007A6043
圣职者 - 玄武=007BC7C1
圣职者 - 白虎=007BC9E0
圣职者 - 白虎的球=006DCEE0
圣职者 - 天谴飓风=007A71FC
圣职者 - 升天镇=007BC4FF
女盗贼 - 手里剑(地下)=00801C98
女盗贼 - 手里剑(空中)=00790FC9
女盗贼 - 暗魂波=008016F7
.子程序 金币触发阿甘左, ,
.局部变量 攻击个数, 整数型
.局部变量 召唤等级, 整数型
.局部变量 触发_值, 整数型
.局部变量 基址, 整数型
.局部变量 计次, 整数型
.局部变量 偏移, 整数型
.局部变量 遍历地址, 整数型
.局部变量 变量, 整数型
.局部变量 次数, 整数型
.局部变量 物品地址, 整数型, , "1"
公告 (“请先往地上扔一金币再召唤阿甘左”))
触发_值 = 内存操作.读代码 (#人物基址)
.如果真 (触发_值 < 1)
    返回 ()
.如果真结束
基址 = 内存操作.读代码 (#人物基址 + “+D4+90”)
次数 = 0
物品地址 [1] = 触发_值 + 13800  ' 十六到十 (“35D4”)
' 召唤等级 = 到整数 (解密 (内存操作.读代码 (#人物基址) + 十六到十 (“10Cc”)))
.如果真 (读内存整数型 (取自身进程ID (), 物品地址 [1]) > 0)
    .变量循环首 (0, 180, 1, 计次)
        偏移 = 4 + 4 × 计次
        遍历地址 = 读内存整数型 (取自身进程ID (), 基址 + 偏移)
        .如果真 (遍历地址 < 16777216)
            到循环尾 ()
        .如果真结束
        变量 = 读内存整数型 (取自身进程ID (), 遍历地址 + 1176)  ' 判断阵营1176
        .如果真 (变量 = 0 或 变量 = 200)  ' 0=人物 200=建筑物、物品
            到循环尾 ()
        .如果真结束
        变量 = 读内存整数型 (取自身进程ID (), 遍历地址 + 180)  ' B4
        .如果真 (变量 ≠ 529 且 变量 ≠ 273 且 变量 ≠ 545)
            到循环尾 ()
        .如果真结束
        变量 = 读内存整数型 (取自身进程ID (), 遍历地址 + 460)  ' 1C8
        .如果真 (变量 = 1)
            到循环尾 ()
        .如果真结束
        APC召唤汇编 (物品地址 [1], 召唤等级 - 8, 412)
        次数 = 次数 + 1
        .如果真 (次数 = 1)
            跳出循环 ()
        .如果真结束
       .变量循环尾 ()
 
 
.子程序 超级瞬移CALL.参数 区域id, 整数型, , 3-塔
.参数 位置id, 整数型, , 7-塔
.局部变量 c1, 整数型
.局部变量 c2, 整数型
.局部变量 c3, 整数型
.局部变量 loc1, 整数型
.局部变量 ebp_14, 整数型
c1 = 十六到十 (#X轴参数)  ' 0128   X轴参数十进制    X轴参数=“00BFEFD0”  
c2 = 十六到十 (#Y轴参数)  ' 0128   Y轴参数十进制    Y轴参数=“00BFEE80”
c3 = 十六到十 (#Z轴参数)  ' 0128   Z轴参数十进制    Z轴参数=“00BFF150”
loc1 = 0
ebp_14 = 十六到十 (#一级参数)  ' 0128                 一级参数=“0129BFD8”
置入代码 ({ 139, 77, 236, 139, 9 }) 
置入代码 ({ 106, 38, 255, 85, 252 }) 
loc1 = 区域id  
置入代码 ({ 139, 77, 236, 139, 9 }) 
置入代码 ({ 106, 1, 141, 85, 240, 82, 255, 85, 248 }) 
loc1 = 位置id 
置入代码 ({ 139, 77, 236, 139, 9 })  
置入代码 ({ 106, 1, 141, 85, 240, 82, 255, 85, 248 }) 
loc1 = 120  
置入代码 ({ 139, 77, 236, 139, 9 }) 
置入代码 ({ 106, 2, 141, 85, 240, 82, 255, 85, 248 }) 
loc1 = 300
置入代码 ({ 139, 77, 236, 139, 9 })  ' ecx
置入代码 ({ 106, 2, 141, 85, 240, 82, 255, 85, 248 })  
loc1 = 5  
置入代码 ({ 139, 77, 236, 139, 9 })
置入代码 ({ 106, 1, 141, 85, 240, 82, 255, 85, 248 }) 
置入代码 ({ 255, 85, 244 })  ,发送发包
 
.子程序 Enter, , , p
.参数 Direction, 整数型, , 0123左右上下,4是上塔,8无视队友
.局部变量 local1, 整数型
.局部变量 local2, 整数型
local1 = 十六到十 (#对话CALL)    '对话CALL="011BD2FC"
local2 = 十六到十 (#过图CALL)    '过图CALL="004A2B10"
置入代码 ({ 96, 139, 77, 252, 139, 9, 139, 137, 32, 160, 32, 0, 139, 73, 72, 255, 117, 8, 255, 85, 248, 97 })
 
.子程序 变换阵营
.参数 阵型, 整数型
.局部变量 首地址, 整数型
.局部变量 次数, 整数型
.局部变量 APC地址, 整数型
首地址 = 内存操作.读代码 (#人物基址 + “+D4+90”)  ' D4 90)
.变量循环首 (首地址, 首地址 + 800, 4, APC地址)
    .如果真 (内存操作.读整数 (内存操作.读整数 (APC地址) + 180) ≠ 273)
        到循环尾 ()
    .如果真结束
    .如果真 (内存操作.读整数 (内存操作.读整数 (APC地址) + 1176) ≠ 0)
        到循环尾 ()
    .如果真结束
    .如果真 (内存操作.读整数 (APC地址) = 内存操作.读整数 (十六到十 (#人物基址)))
        到循环尾 ()
    .如果真结束
    .如果真 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (APC地址) + 7876) + 16) = 35939)  ' 武器ID
        到循环尾 ()
    .如果真结束
    .如果真 (内存操作.读整数 (内存操作.读整数 (内存操作.读整数 (APC地址) + 7876) + 16) = 27988)  ' 武器ID
        到循环尾 ()
    .如果真结束
    .如果真 (APC地址 > 0)
        阵营调用代码 (APC地址, 阵型)
    .如果真结束
 
.变量循环尾 ()
 
.子程序 阵营CALL
.参数 对象, 整数型
.参数 数值, 整数型
.局部变量 代码, 字节集
置汇编代码({ }) 
Pushad ()
Mov_ESI_Ptr (对象)
Mov_EAX_ESI ()
Mov_EAX_Ptr_EAX_Add (0)
Add_EAX (十六到十 (“2EC”))
Mov_EBX_Ptr_EAX_Add (0)
Push (数值)
Mov_ECX_ESI ()
Call_EBX ()
Popad ()
ret( )
代码 = 取汇编代码( )  
调用代码 (代码)
.子程序 自定义攻击
.参数 人物基址, 整数型
.参数 X轴距离, 整数型
.参数 Y轴距离, 整数型
.参数 Z轴距离, 整数型
.参数 伤害值, 整数型
.参数 技能ID, 整数型
置入代码 ({ 139, 117, 8, 139, 54, 184, 104, 239, 11, 1, 139, 0, 185, 108, 239, 11, 1, 139, 9, 106, 0, 106, 0, 139, 22, 80, 81, 106, 0, 106, 4, 255, 117, 20, 255, 117, 16, 255, 117, 12, 106, 0, 106, 0, 255, 117, 24, 255, 117, 28, 139, 206, 255, 146, 224, 2, 0, 0 })
 
.子程序 技能模拟CALL
.参数 人物基址, 整数型
.参数 X轴坐标, 整数型
.参数 Y轴坐标, 整数型
.参数 Z轴坐标, 整数型
.参数 伤害, 整数型
.参数 技能ID, 整数型
.参数 触发基址, 整数型, , 可以是人物触发 召唤触发
.参数 CALL地址, 整数型, , 即模拟CALL
置入代码({139, 117, 8, 139, 54, 161,104,239,11,1, 139, 13,108,239,11,1, 106, 0, 106, 0, 80, 139, 22, 106, 62, 106, 0, 106, 4, 106, 0, 106, 0, 255, 117, 20, 255, 117, 16, 255, 117, 12, 255, 117, 24, 255, 117, 28, 139, 125, 32, 54, 139, 63, 87, 139, 206, 255, 85, 36 })
.子程序 物品CALL
.参数 物品基址, 整数型
.参数 物品代码, 整数型
.局部变量 代码, 字节集
置汇编代码({ }) 
Pushad ()
Mov_ECX_Ptr (物品基址)
Mov_EDX_Ptr_ECX_Add (0)
Mov_EAX_EDX ()
Add_EAX (十六到十 (“4CC”))
Mov_EBX_Ptr_EAX_Add (0)
Push (物品代码)
Call_EBX ()
Popad ()
ret( )  
代码 = 取汇编代码( )  
调用代码 (代码)
 
.子程序 启动SSS
内存操作.写代码 (#评分基址 + “+5f=100”)
   评分基址=”011B7990“
 
 
.子程序 APC召唤
.参数 等级, 整数型
.参数 代码, 整数型
置入代码 ({ 139, 53, 12, 59, 33, 1, 139, 6, 106, 0, 106, 0, 104, 32, 56, 64, 0, 106, 0, 106, 0, 104, 255, 255, 0, 0, 106, 0, 106, 0, 106, 4, 139, 206, 255, 144, 204, 0, 0, 0, 80, 139, 6, 106, 0, 106, 5, 106, 6, 255, 117, 8, 139, 206, 255, 144, 220, 1, 0, 0, 139, 22, 80, 255, 117, 12, 139, 206, 255, 146, 244, 2, 0, 0 })

注:源自网络,非诗人所原创!

打印
分享到:
复制链接

发表评论

*

* (保密)

Ctrl+Enter 快捷回复

会员登录关闭

记住我 忘记密码

注册会员关闭

小提示: 您的密码会通过填写的"电子邮箱"发送给您.

/** **/