蓝盟诗人[LUC]蓝客联盟

忘记密码

桂花里的吸怪写法

2011-04-19 07:54 作者: 来源: 本站 浏览: 2,079 views 我要评论 字号:

.版本 2
.支持库 iext
.子程序 _按钮11_被单击, , , APC自动吸怪
.如果 (时钟7.时钟周期 = 0)
时钟7.时钟周期 = 2000
窗口1.透明标签1.标题 = “APC自动吸怪开启”
.否则
时钟7.时钟周期 = 0
窗口1.透明标签1.标题 = “APC自动吸怪关闭” '
.如果结束

.子程序 _时钟7_周期事件, , , APC自动吸怪
.局部变量 人物地址, 整数型
.局部变量 a, 整数型
.局部变量 i, 整数型
.局部变量 怪物数量, 整数型
.局部变量 怪物基址2, 整数型
.局部变量 人物x, 整数型
.局部变量 人物y, 整数型
.局部变量 临时变量, 整数型
.局部变量 地图, 整数型

 

人物地址 = 返回BOSS地址 (273)

地图 = 内存操作.读整数 (内存操作.读整数 (人物地址) + 十六到十 (“D4”))

.如果真 (地图 ≤ 0)

返回 ()

.如果真结束

怪物数量 = (内存操作.读整数 (地图 + 十六到十 (“94”)) - 内存操作.读整数 (地图 + 十六到十 (“90”))) ÷ 4

.计次循环首 (怪物数量, )

a = 内存操作.读整数 (地图 + 十六到十 (“90”))

怪物基址2 = 内存操作.读整数 (a + i)

i = i + 4

临时变量 = 内存操作.读整数 (怪物基址2 + 十六到十 (“B4”))

.如果真 (临时变量 ≠ 529 且 临时变量 ≠ 273)

到循环尾 ()

.如果真结束

.如果真 (内存操作.读整数 (怪物基址2 + 十六到十 (“498”)) ≠ 100) ' 这里变了

到循环尾 ()

.如果真结束

人物x = 读内存小数型 (-1, 内存操作.读整数 (人物地址) + 十六到十 (“178”))

人物y = 读内存小数型 (-1, 内存操作.读整数 (人物地址) + 十六到十 (“17C”))

写内存小数型 (-1, 内存操作.读整数 (怪物基址2 + 十六到十 (“C8”)) + 十六到十 (“C”), 人物x) ' 这里变了

写内存小数型 (-1, 内存操作.读整数 (怪物基址2 + 十六到十 (“C8”)) + 十六到十 (“10”), 人物y)

写内存小数型 (-1, 内存操作.读整数 (怪物基址2 + 十六到十 (“C8”)) + 十六到十 (“14”), 0)

.计次循环尾 ()

打印
分享到:
复制链接

发表评论

*

* (保密)

Ctrl+Enter 快捷回复

会员登录关闭

记住我 忘记密码

注册会员关闭

小提示: 您的密码会通过填写的"电子邮箱"发送给您.

/** **/